Tutorials - encoutered errors maybe?

Hey there.

I’m trying to learn from your tutorials and I hope this is the correct category to post this.

I’m having trouble following your tutorials through the google colab it gives me an error message in the first tutorial “01_The_Basic_ … etc” whe trying to load the data it says it can’t find GLIBCXX_3.4.26. I have been trying to rummage around a little bit and can find the 3.4.25 version but I cannot get it to install 3.4.36 correctly.

After this I tried to move to a local setting and I got a little further and am now at “05_Creating_Models_with_…etc” but when trying to use the TorchModel it gives me the following error: image

I hope I can get some guidance, also if this is not the correct place to post this please tell me.


There’s a workaround for the RDKit error (the cause of the GLIBCXX_… error) at https://github.com/deepchem/deepchem/issues/2413. We’re working to find a better fix, hopefully soon. Thanks for your patience!

For the local version, you might not have PyTorch installed or could possibly be on an old version of DeepChem. Could you check both of those are set correctly?

Hi, thanks for the quick response.

I used pip3 to install torch and deepchem yesterday so I believe they are up to date

also the exact same thing I’m trying to do works perfectly fine with the KerasModel, so atleast deepchem should be installed correctly

I’m not sure what’s happening here, but usually these types of errors happen when there are library mismatches somewhere. Can you try making a fresh conda environment to install deepchem and its dependencies in? That usually works nicely for new installs

Okay so for the torch problem I gave up and stopped for the day. When I returned today it worked on my local system for some reason with zero changes since last I tried… maybe I needed a restart before the pytorch package was visible? I don’t know.

I’m not using conda. I installed the packages with the following commands.

For RDKit:

sudo apt-get install python-rdkit librdkit1 rdkit-data

For tensorflow, pytorch and deepchem:

pip3 install tensorflow
pip3 install torch
pip3 install deepchem

For some reason it works now… which is unsatisfactory when it comes to solving problems but I wont complain, thanks for your help.